实现会员上机的充值、缴费等功能。

对于临时会员上机时，需要事先缴纳押金，插入上机卡后，系统会自动创建临时会员记录，输入实收金额，单击［押金/充值］，系统将押金金额写入会员账户上。

对于正式会员，可以实现账户充值。插入上机卡后，输入实收金额，单击［押金/充值］，系统将充值金额写入该会员账户上。

特殊说明：

充值时，对于“消费优惠”类型的会员，实收金额即是充值金额；对于“充值优惠”


该功能实现用户下机的结账，对于临时会员需要返还剩余押金，具体操作根据会员类型有所不同。

Ø 如果用户没有在客户机结账

ü 对于临时会员：系统自动读取上机卡中的押金余额，收银员选择结帐后，系统将该临时会员账户清零，修改上机日志，将上机卡解锁，再选择退费后，收银员将剩余押金返还用户。

ü 对于正式会员：系统自动读取上机卡中的余额，将修改会员账户，修改上机日志，将上机卡解锁。

Ø 如果用户已经在客户机结账

ü 对于临时会员：在客户机结账后，系统已经将上机卡中的余额更新到会员账户上，修改了上机日志，并将上机卡解锁。所以此时只需要根据卡号读取会员的账户余额（即剩余押金），显示给收银员，由收银员将剩余押金返还用户。

ü 对于正式会员：在客户机结账后，已经完成所有操作，无需再结账。

Ø 临时用户批量结账并退费

系统对临时上机的会员支持批量退费操作，满足团体下机的快速结账。此功能主要适用于押金用户，批量结账时，可以将团体用户的押金和消费进行汇总，最终向操作员显示需要退还用户的总金额。单击［批量退费］，窗体如下图：

    依次插入等待结帐的临时会员卡，单击［确定］，系统将该临时会员卡做结帐处理，并自动计算应退金额，收银员就可以依据显示在列表下面的金额总计进行退费。

特殊说明：

下机结账时，需要判断用户的上机消费是否小于系统设置的“最小上机费用”，如果小于系统设定的最小上机费用，则按“最小上机费用”扣除或收取费用。

充值优惠类型的会员不支持批量退费操作。

如果会员在未结帐的情况下丢失上机卡，需要同网吧协商处理解决办法，本系统建议程序操作中可以先删除该会员，再从杂费中填入应返还给会员的余额。


上机用户可以在未结账的情况下在线充值，该功能可以修改用户账户余额中的金额（加上续存金额），同时向终端客户机发送续存押金命令，终端客户机向用户的上机卡中增加续存的金额，完成用户在不下机的情况下追加余额。

输入要在线充值的机器号（唯一标识），单击［添加］后，将要充值的机器增加到下面的列表中(可重复操作，添加多个机器)，再输入充值金额，选择［在线充值］即可。

特殊说明：

由于一些特殊原因，如断电、网络中断、客户端拔卡等原因造成的在线充值失败的情况，用户上机时会有提示.此时，可到收银端通过“在线充值”中的“失败处理”功能对该用户上机卡重新充值。如下图：


用户上机过程中有可能需要租用网吧提供的一些物品，如摄像头等物品。该功能可以实现对这些物品的定义、租借和返还操作。

单击“物品定义”，可以对网吧中可租借的物品进行设置。包括物品名称、押金和租金。

单击［租借］，会弹出租借窗体，如下图：

可直接插入会员卡或通过单击［查找用户］功能以指定的查询条件查找到需要租借物品的会员，再进行租借操作。查找用户窗体如下图：

特殊说明：

物品租借一律采用现金交付方式。即：无论该会员帐户是否处于结帐、未结帐或冻结状态，都可以进行物品租借。


用户有时可能会选择包时段的上机方式，如包天、包月等；或者选择包指定的机器上机，如包大厅的15号机器一星期或一个月等。系统首先根据用户上机卡得到对应的会员信息，然后确定用户要包机的类型、终端区域和指定的机器，设置用户的包机时间段，最后由人工根据会员类型、终端区域和包机时长确定用户的包机费用。包机费用采用事先扣除的策略。包机登记成功后，用户在包机时段上机将不再收取任何费用，用户可以在指定的终端上机，如有需要，还可更换包机，但不能到未指定的终端上机。

插入上网卡可直接读取要包机的用户信息，或单击［查找用户］查询要包机的用户信息。

    根据需要选择包机时段和机器，确定后，包机成功。

特殊说明：

包机类型中除“任意时段包机”外，其余的类型都是在“包机快捷设置“和“计费时段设置”中的“特殊时段设置”中设置的。

用户包机必须保证当前用户是结帐状态，即未结帐或冻结的用户不能包机。

包机登记时，如果是用卡付费，用户的帐户余额要足够包机费用。

用户一旦包机，在该包机时段，只能在指定的终端上机。


对于因某些特殊原因，如原包机出现故障，需要更换机器时，可通过此功能来实现用户包机换机的操作。

插入上网卡可直接读取要换机的用户信息，或单击［查找用户］查询要换机的用户信息，如果该用户有包机记录，会显示在下面的列表中。选中要换机的包机信息，再单击［换机］，弹出窗体如下图：

选择更换的机器以及相应的金额后，单击［结算］后，完成包机换机操作。

特殊说明：

用户包机换机必须保证当前用户是结帐状态，即未结帐或冻结的用户不能换。

包机换机时，如果是卡付费，需要判断用户的帐户余额是否足够新包机费用。


对于用户包机或每天的特定时段上机（也是包时方式，如包夜），用户有可能中途要求取消。该功能可以提供灵活的操作，满足用户取消包机的要求。

首先系统根据用户的上机卡可以调出并显示用户的包机信息，如用户类型、包机起始时间、当前时间、已消费时间、包机区域、包机总金额等，由系统管理员人工确定最终应返还用户的剩余包机金额。但如果超过包机时段，系统将不允许取消包机。

特殊说明：

用户是否允许取消包机需要根据系统管理中“运营参数设置”来指定，如果系统设置为包机用户不能中途取消，则该功能菜单隐藏。

用户取消包机前，系统首先需要插卡结帐，同步帐户和数据库中的金额。

对于所有用户（包括临时会员）都将取消包机的金额加到用户帐户的余额中。

取消包机的退费会自动加回到帐户里，如果会员需要返还现金，可以用“退费”操作返还现金，详见“会员退费”章节。


在一些情况下，用户可能在未到包机结束时间的情况下，提前下机，此时，可通过此功能查询到该机器，强制取消该用户的包机设置。

根据实际情况选择相应的查询条件后，单击［查询］，即可查到符合条件的包机用户，选中记录，点［强制取消］即可。


此功能用来对经常性的包机模式进行定义，以便包机登记时能够快捷操作。如网吧经常用到的包4小时5元。

单击［增加］，建立新的包机模式：

    根据需要进行设置即可。设置完成后，即可在包机中的“包机类型”列表中看到这个类型。


系统管理员如果在会员类型定义时设置某种类型的会员可以退费，则执行该功能可以将会员账户上的余额退还给用户。

对于“消费优惠”类型的会员，账户的余额即是最终的退费金额。对于“充值优惠”类型的会员，系统列出该会员的历史充值记录（可能存在多种优惠策略），由操作员自行判断并指定最终的应退费金额。

特殊说明：

本系统不推荐“充值优惠会员”退费，如果系统设置允许退费，系统列出该用户的充值和转账记录，由操作员自行指定退费金额。

会员退费时需要插入上机卡，并输入上机卡密码，防止他人冒名非法退费。


定义网吧可出售的商品的名称、价格等信息，并实现收入和支出的记录、查询、统计等功能。此功能属于独立的模块，负责管理网吧日常商品的收入和支出。

单击“杂项定义”，可以定义网吧中的各项杂费名称，包括收入和支出。

单击［杂项收支］，会弹出收支窗体，如下图：

可直接输入或选择相应的杂费名称，再填入其他信息即可。

单击［杂项明细表］，会弹出杂项收支明细，如下图：

    操作员可根据不同的需要查询各项杂费明细，也可将查询结果打印出来，具体打印操作见打印章节。

特殊说明：

杂项管理一律采用现金交付方式。